It’s not news anymore that Mozilla is stopping support for NPAPI (Netscape Plugin API). With the release of Firefox 52 version, I believe that only Flash plugin is enabled by default.

I’ll skip the discussion about NPAPI plugins and Mozilla’s decision to stop the support, however the reality is that for me it has a strong impact in certain areas. One of this areas is the F5 BIG-IP, specifically the APM and possibility to launch Application (like RDP) from the Webtop interface.

I’m relying heavily on a F5 BIG-IP VE machine to connect to my home lab when I’m remote. The Webtop functionality gives me the possibility to use only a Browser to connect to my applications at home, keeping me away from any F5 client installation on the machine that I use. Usually this machine is my MacBook or PC, and the F5 client installation should not be a big thing, however I like the clientless option.

The F5 Webtop functionality is possible due to a NPAPI plugin called “F5 Network Host Plugin” which usually installs in the browser when you access the F5 APM. So yes, you still need to install something, but this browser plugin is easy to install / remove when compared with a F5 client.

One morning I wake up to find out that my Firefox browser was silently upgraded in the background and instead of being able to launch an Application from the F5 Webtop interface I see this:

Useless to say that the plugin was already installed and everything seemed to be fine. Googling around I could find a lot of information why is not working, but no workaround until I read this article on the F5 DevCentral page.
F5 is aware of the problem, they are working on a solution but so far everything points out to use of the F5 client.

Until Firefox 51 everything was still fine but with the release of Firefox 52 you will get the error showed above. Long story short, for now, there is a workaround which suppose to work fine on Firefox 52 and the upcoming 53 version.

You need to create in Firefox 52 a configuration parameter called “plugin.load_flash_only” and set the value to “False”. Remember that this parameter is not there, so don’t just search for it…create it.

  1. Head to the Firefox URL bar and type about:config.
  2. Accept the responsibility that you’ll not destroy your Firefox installation.
  3. Right click
  4. Chose New > Boolean from the menu
  5. In the newly open window type: plugin.load_flash_only
  6. Set the value to: False

In the end you’ll see something like this:

Remember that I said in the first line that only Flash plugin is still enabled by default? This setting reverse that setting, by saying that not only Flash plugin should be enabled.

Not sure what I’ll do for future. Not to upgrade Firefox 52 (and possible 53) to the next release is not a long term option and from security perspective is a disaster. To keep a parallel installation of Firefox just to reach my trusted URL…doable, but still a bit of a hassle. I hope F5 will come up with a solution.

F5 BIG-IP Plugin with Firefox 52 workaround
Tagged on:                 

Leave a Reply

%d bloggers like this: